Faster Payment Update
Incident Report for
thinkmoney
Resolved
This incident has been resolved.
Posted
Apr
27
,
2026
-
16:44
UTC
Monitoring
Faster Payments and card controls have now been restored and are working as normal.
We’re sorry for the disruption caused and thank you for bearing with us while we resolved the issue.
Posted
Apr
27
,
2026
-
07:23
UTC
×
Subscribe to Incident
Subscribe to updates for
Faster Payment Update
via . You'll receive .