Card Transaction Issues

Incident Report for thinkmoney

Resolved

This incident was resolved with customer impacted notified.
Posted May 18, 2026 - 06:38 UTC

Monitoring

Services have been restored and we're continuing to monitor them.
Posted May 15, 2026 - 15:12 UTC

Identified

We're currently experiencing an issue that's affecting some card activity at the moment. We're really sorry for any disruption and we're working to resolve this as soon as possible. For more information and the latest updates, please visit our status page: status.thinkmoney.co.uk
Posted May 15, 2026 - 12:22 UTC
This incident affected: Debit Cards.