Update -Services have largely been restored, but customers may still experience some interruptions while systems are getting back on track.
Monitoring - We are continuing to monitor performance closely and will share updates if anything changes
Posted Apr 28, 2026 - 08:01 UTC
Update
Services have largely been restored, but some customers may still experience occasional interruptions while systems fully stabilise. We are continuing to monitor performance closely and will share updates if anything changes.
Posted Apr 27, 2026 - 19:39 UTC
Monitoring
Our payment processing partner has identified the cause of the issue affecting card transactions and has confirmed this is now resolved. We apologise for the disruption to your service and thank you for your patience.
Posted Apr 27, 2026 - 16:44 UTC
Identified
Our payment processing partner has identified the cause of the issue affecting card transactions and is actively working to resolve it. We apologise for the disruption to your service and will provide a further update as soon as there is a change in status.
Posted Apr 27, 2026 - 13:28 UTC
Investigating
We are aware that some customers are having an issue with using their card at the minute - we're really sorry if this is causing any disruption for you and we're working to sort it as soon as possible.
Posted Apr 27, 2026 - 10:44 UTC
This incident affected: Mobile App and Debit Cards.