Inbound and outbound Faster Payment delays
Incident Report for thinkmoney
Resolved
This incident has been resolved.
Posted Sep 14, 2024 - 21:05 UTC
Investigating
We are currently experiencing a delay with both inbound and outbound Faster Payments. We are working to resolve this as soon as possible and we apologise for the inconvenience.
Posted Sep 14, 2024 - 17:08 UTC
This incident affected: Faster Payments.