The issue affecting our app, faster payments and card management has now been resolved.
Posted Jul 28, 2026 - 22:25 UTC
Investigating
We're currently experiencing an ongoing issue that's affecting our app, faster payments and card management. We're really sorry for any disruption and we're working to resolve this as soon as possible. For more information and the latest updates, please visit our status page: status.thinkmoney.co.uk.
Posted Jul 28, 2026 - 18:25 UTC
This incident affected: Online Banking, Debit Cards, Faster Payments, and Incoming Payments.