Payments delay
Incident Report for
thinkmoney
Resolved
Issue is now resolved
Posted
Apr
09
,
2026
-
14:08
UTC
Update
We are continuing to work to fix this issue.
Posted
Apr
09
,
2026
-
10:14
UTC
Identified
The issue has been identified and we working to release any pending payments. Any payment send / received after 8:21am are unaffected by this issue.
Posted
Apr
09
,
2026
-
08:29
UTC
Investigating
We are currently investigating an issue where payments are taking longer than usual to reach your accounts.
Posted
Apr
09
,
2026
-
06:30
UTC
This incident affected: Faster Payments and Incoming Payments.
×
Subscribe to Incident
Subscribe to updates for
Payments delay
via . You'll receive .