Our payment processing partner is continuing to fix the issue affecting Faster Payments out and card controls, and we are working with them to restore service as soon as possible.
Posted Apr 26, 2026 - 22:16 UTC
Update
Our payment processing partner has identified the issue affecting Faster Payments out and card controls, and we are working with them to restore service as soon as possible
Posted Apr 26, 2026 - 19:46 UTC
Update
Faster Payments- We're aware of an ongoing issue affecting the sending of Faster Payments in the app for some customers. Card- We're aware of an ongoing issue affecting the facility for blocking/unblocking cards and viewing PINs in the app Work is ongoing to restore full service.
Online Payments- The issue has been identified and resolved.
Posted Apr 26, 2026 - 16:25 UTC
Identified
Card- We are aware of an ongoing issue blocking/unblocking their cards, and viewing their PIN in the app. Online Payments- The issue has been identified and resolved. Faster Payments- We're aware of an ongoing issue affecting the sending of Faster Payments in the app for some customers.
Posted Apr 26, 2026 - 14:20 UTC
Update
Investigating Card- We are aware of an ongoing issue blocking/unblocking their cards, and viewing their PIN in the app. Online Payments- We are investigating an issue affecting 3D Secure (3DS) authentication. Some customers may not be able to complete online transactions that require 3DS verification. Faster Payments- We're aware of an ongoing issue affecting the sending of Faster Payments in the app for some customers.
Our teams are working to identify the cause and get our services restored - thankyou for your patience
Posted Apr 26, 2026 - 13:46 UTC
Update
Investigating
Card- We are aware of an ongoing issue affecting customers blocking/unblocking their cards, and viewing their PIN in the app.
Online Payments- We are investigating an issue affecting 3D Secure (3DS) authentication. Some customers may not be able to complete online transactions that require 3DS verification.
Faster Payments- We're aware of an ongoing issue affecting the sending of Faster Payments in the app for some customers.
Our teams are working to identify the cause and get our services restored - thankyou for your patience
Posted Apr 26, 2026 - 12:33 UTC
Update
We're aware of an ongoing issue affecting the sending of Faster Payments in the app for some customers.
Posted Apr 26, 2026 - 11:30 UTC
Investigating
We are investigating an issue affecting 3D Secure (3DS) authentication. Some customers may not be able to complete online transactions that require 3DS verification. Our teams are working to identify the cause.
Posted Apr 26, 2026 - 07:35 UTC
This incident affected: Mobile App and Faster Payments.