Faster Payment inbound
Incident Report for
thinkmoney
Resolved
This incident has been resolved.
Posted
Aug
27
,
2026
-
17:41
UTC
Investigating
We are aware of an issue that is causing delays for customers receiving Faster Payments. We are working to resolve this as soon as possible and will provide further updates.
Posted
Aug
27
,
2026
-
17:18
UTC
This incident affected: Incoming Payments.
×
Subscribe to Incident
Subscribe to updates for
Faster Payment inbound
via . You'll receive .