Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 26, 2026 - 05:18 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 26, 2026 - 01:00 UTC
Scheduled
From 2am to 7am on Sunday 26 April, all our services will be down for planned maintenance. This means that during this time, you won’t be able to use your card or access our app. Any payments coming into your account will be held in a queue and you won’t be able to make payments until the work is finished. We’re sorry for any inconvenience this may cause.