Card order request.
Incident Report for
thinkmoney
Resolved
Card ordering in no functional in app.
Posted
Jul
22
,
2025
-
07:11
UTC
Investigating
We’re looking into an issue with ordering cards
Posted
Jul
21
,
2025
-
18:46
UTC
This incident affected: Mobile App.
×
Subscribe to Incident
Subscribe to updates for
Card order request.
via . You'll receive .